Announcement

Collapse
No announcement yet.

User Profile

Collapse

Profile Sidebar

Collapse
A+MAESTRO
A+MAESTRO
  •  
  • Filter
  • Time
  • Show
  • Source
Clear All
new posts

  • A+MAESTRO
    replied to Bits wanted for 315
    http://www.damenenkroes.nl/

    Damen & Kroes had front and rear in stock circa May 2020.

    No idea if they still do or what prices would be now. I emailed them in English and they responded in English.

    Was originally signposted there by this forum.
    See more | Go to post

    Leave a comment:


  • A+MAESTRO
    replied to A series, won't warm start.
    Not to worry, I have discovered my problem.

    Me!


    Firing order correct, except not quite, all one plug plug out on the dizzy.

    The words I have called myself

    Many thank yous for your suggestions. I had a little trouble with running...
    See more | Go to post

    Leave a comment:


  • A+MAESTRO
    replied to A series, won't warm start.
    Hi Pete,

    I've actually not had chance until today to work on the car.

    I got a bit hissy with it and bought new plugs, leads, cap and rotor arm because I couldn't think what was causing it as it's getting fuel and it's not firing in the slightest.

    I gave it a short...
    See more | Go to post
    Last edited by A+MAESTRO; 13th January 2022, 20:36.

    Leave a comment:


  • A+MAESTRO
    replied to A series, won't warm start.
    Hi ,

    Quick update. It's not running at all. It backfires if I crank it long enough.

    Now for the "I think I broke it more and should have got it running first to know for sure" bit...

    Noticed it was leaking petrol from the bottom of the carb from the...
    See more | Go to post

    Leave a comment:


  • A+MAESTRO
    replied to A series, won't warm start.
    Thanks Jeff.

    I went out earlier to have a go at starting, the last few days I've only been able to get one start a day before the daylight disappears. That's with up to 3 hours between starting - not what I'd have called warm.

    To my surprise it started for the second time today,...
    See more | Go to post

    Leave a comment:


  • A+MAESTRO
    replied to A series, won't warm start.
    This started out the blue, I drove to the supermarket a few nights ago and had to get towed home.

    I think I need to check the fuel is getting to the intake and if the overflow is clear if not. I don't remember seeing where the overflow goes on these. I used to have a tube on the mini that...
    See more | Go to post

    Leave a comment:


  • A+MAESTRO
    started a topic A series, won't warm start.

    A series, won't warm start.

    Hi all,

    My A+series maestro won't start warm. Starting from cold it runs like a dream. I'm hoping you may have some ideas that will help.

    I've checked the following:
    Spark plugs (gaps correct, condition a little sooty, cleaned and reused)

    HT leads (visually...
    See more | Go to post
No activity results to display
Show More
Working...
X